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With the Contacts Manager+ for UIQ phones application, you can export/import contacts, 
templates and group definitions (or folders) from/to the Symbian UIQ phone contacts database, 
using a textual file (CSV, TXT) with delimiters.  
 
Testing Version (Demo) 
 
An unregistered version should be used only for trial testing. Its functionality is limited – it processes 
only 25 contacts. 
 
Full Version 
 
By registering, the trial version becomes the fully functional one. Enter your registration code in the 
Tools->Registration field box. The information about ordering of registration codes can be found at the 
http://www.communicator.cz website. 
 
Export of Contacts 
 
By pressing the Export button (or selecting Contacts->Export contacts), you can store data from the 
default contacts database into a text file with delimiters. Confirm by pressing the Yes button. The 
dialog is displayed, in which you can set the name and path of the export file. Pre-selected folder for 
saving the file is the ‘Internal\Other’ folder. You can save the file to any other folder but note that the 
import function can see only content of ‘Internal\Other’ and ‘External\Other’ folders. Default export 
format is CSV file, with comma as a delimiter, and quotes as a text qualifier. CSV file parameters can 
be changed by pressing the Settings button (or in the Tools->Settings item).  
 
As soon as the export is finished, you can use the file in the usual way, e.g. send the file to another 
device (PC, PDA, etc). Format/protocol of the exported file is the same as in Contacts Manager(+) for 
Series 60 or for Nokia 92xx. 
 
A file in the Contacts Manager format can be imported into Symbian UIQ phone, Symbian Series 60 
phone, Nokia 9210/9290, a spreadsheet or database application on PC, etc. Read more about import 
in further text (‘Import’ chapter). 
 
File Renaming/Sending/Deleting 
 
For sending the file to other device (PC, PDA, etc), just run File Manager, select the file and use usual 
procedure – Beam or Send as and choose proper sending method. 
 
Other file operations, such as renaming, deleting, etc, can be done in a similar way. 
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Settings 
 
By pressing the Settings button (or selecting Tools->Settings), you can open settings, where you can 
set parameters and content of the exported file.  
Settings can be (optionally) saved by the application closing.  
Default (factory) settings are marked in bold in the list below. 
 
Export format tab: 
 

Field separator – It can be either comma or semicolon (CSV format) or tab (TXT format).  
 

Text qualifier – Quotes/apostrophes/nothing as a qualifier in CSV format (commas/semicolons 
delimited) can be used. TXT format (tabs delimited) usually doesn’t use text qualifier. 
Caution: Don't use the "None" option in the text qualifier settings together with 
commas/semicolons delimiters unless you have good reason to do so. This qualifier option 
should be set only if "Tab" is set as a delimiter. 

 
End of line (EOL) – As an end-of-line, the CR (0x000D) character is set by default. Optionally, 
user can set CR+LF (0x000D 0x000A) as an end of line instead. 

 
Line break within a field – If a field contains (in a formatted item) a line break, this line break is 
– according to the current settings – either replaced by space, exported as the LF (0x000A) 
character or as the textual escape sequence ”\n“. As ‘line break’ in the source data is 
recognized any of the following formatting characters: LSEP (LINE SEPARATOR, 0x2028), 
PSEP (PARAGRAPH SEPARATOR, 0x2029), FF (FORM FEED, 0x000C), LF (LINE FEED, 
0x000A), CR (CARRIAGE RETURN 0x000D) or CR+LF (0x000D 0x000A). 
Formatted items are: Note, formatted address (Address/LABEL), and formatted name 
(Name/FN). 

 
Export content tab: 
 

Contacts – Choose whether only contacts from the phone memory are to be exported, or 
SIM contacts, too.  

 
Groups – You can determine whether groups (folders) definitions will also be included into the 
result file (Yes/No). 

 
Templates – You can set whether templates will be included into the result file (Yes/No). 

 
Picture data – If you set Yes, the ‘Picture’ field will contain whole contact picture data (JPEG 
format, Base64 encoding), setting No means that only the ‘TRUE’ flag (where acceptable) is 
written in this field.  

 
Private notes – If set to Yes, all notes are exported; if set to No, notes marked as “Private” are 
not included into the export file. If the Yes option is set the private notes are exported as 
renamed to “Private” for better recognition in the result export file. 
 

More information about items exporting can be found in the “Export” chapter. 
 
Closing the Application 
 
The application is closed by selecting File->Exit. 
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Exported File – the Format and the Structure 
 
As a result of export, you will get delimited textual file with data ordered into 56 “columns” (v. 1.0). 
Delimiters are either commas or semicolons (CSV format) or tabs (TXT format) depending on your 
choice (current settings). Unicode coding is used.  
 
Exported “table” has three leading rows. First of them contains file format identifiers and must not be 
changed because if it is missing or changed, the file cannot be imported back. The second row 
contains column headers that are very important for cells data identity – always keep these numerical 
identifiers untouched. The third row contains descriptions of numerical identifiers in the second row – 
user can freely modify (edit, translate) these descriptions in the third row. They are important for user 
(as data comments), not for program itself or its data. 
 
Since the file format is CSV, you have to determine its parameters (field separator, text qualifier, end-
of-line character, line-break character). You can also set whether exported file will contain only 
contacts or also group definitions, and whether contact pictures data will be exported. For more 
details, see “Settings” chapter. 
 
Columns Headers and Their Order (v. 1.0):  
 
Enumbering       Header                                              Info Exclusivity 
0000 ID Unique ID of the contact card  
1100 Last name Family name subfield of Name field Single
1200 First name Given name subfield of Name field Single
2100 Ringing tone Path and filename of the contact’s individual ringing tone Single
6000 Company Organization name field Single
6100 Job title Job title field Multi 
4000 Tel Tel field (shown as Phone (w)) Multi 
4002 Tel (Business) Tel field with property Multi 
4003 Tel (Home) Tel field with property Multi 
4006 Other Tel Tel field renamed with user string Multi 
4007 Other Tel - desc. User string in Tel (.....) field if it is renamed  
4100 Tel GSM Tel GSM field (shown as Mobile (w)) Multi 
4102 Tel GSM (Business) Tel GSM field with property Multi 
4103 Tel GSM (Home) Tel GSM field with property Multi 
4106 Other Tel GSM Tel GSM field renamed with user string Multi 
4107 Other Tel GSM - desc. User string in Tel GSM (.....) field if it is renamed  
4300 Fax Fax field (shown as Fax (w)) Multi 
4302 Fax (Business) Fax field with property Multi 
4303 Fax (Home) Fax field with property Multi 
4306 Other Fax Fax field renamed with user string Multi 
4307 Other Fax - desc. User string in Fax (.....) field if it is renamed  
4500 Mail Email field (shown as Email (w)) Multi 
4502 Mail (Business) Email field with property Multi 
4503 Mail (Home) Email field with property Multi 
4506 Other Mail Email field renamed with user string Multi 
4507 Other Mail - desc. User string in Email (.....) field if it is renamed  
4700 URL URL field Multi 
4702 URL (Business) URL field with property Multi 
4706 Other URL URL field renamed with user string Multi 
4707 Other URL - desc. User string in URL (.....) field if it is renamed  
4800 DTMF **) DTMF field Multi 
4806 Other DTMF **) DTMF field renamed with user string Multi 
4807 Other DTMF - desc. **) User string in DTMF (.....) field if it is renamed  
3300 Street Street subfield of Address field Single
3600 ZIP/Postal code ZIP/Postal code subfield of Address field Single
3400 City City subfield of Address field Single
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3500 State/Province State/Province subfield of Address field Single
3700 Country/Region Country/Region subfield of Address field Single
3302 Street (Business) Street subfield of Business address field Single
3602 ZIP/Postal code (Business) ZIP/Postal code subfield of Business address field Single
3402 City (Business) City subfield of Business address field Single
3502 State/Province (Business) State/Province subfield of Business address field Single
3702 Country/Region (Business) Country/Region subfield of Business address field Single
3303 Street (Home) Street subfield of Home address field Single
3603 ZIP/Postal code (Home) ZIP/Postal code subfield of Home address field Single
3403 City (Home) City subfield of Home address field Single
3503 State/Province (Home) State/Province subfield of Home address field Single
3703 Country/Region (Home) Country/Region subfield of Home address field Single
1900 Picture Contact picture field Single
7000 Note ***) Note field Single
7006 Other Note ***) Note field renamed with user string  
7007 Other Note - desc. ***) User string in Note (.....) field if it is renamed  
0300 Member ID of groups that the contact belongs to Single
9906 Misc. Various conceded, hidden and special fields and items  
9999 Misc. - type Property/type/subtype tag to specify type of „Mics.“ item  
9907 Misc. - desc. User string in the field „Misc.“ if it is renamed  
 
**) DTMF field type can be created in the P800/900 as ‘Phone (h)’ field - its content must begin with “p” 
character. Fields ‘Phone (h)’ and ‘Phone (w)’ with the content beginning with “p” are exported into the 
‘DTMF’ column, and the leading “p” is cut off. If imported into the P800/900, data from ‘DTMF’ column 
is imported into the ‘Phone (h)’ field; the leading “p” is added. Renamings are kept. 
 
***) Exporting of notes marked as “Private” is dependent on the Settings. 
 
Note: 
 
Internal Contacts application in SE P800/900 phone doesn’t use – in comparison with devices like 
Nokia Series 60 or 80 – field types Phone, Mobile, Fax, or Email, without “Work” (w) or “Home” (h) 
properties. These fields cannot be created internally, but when they are imported (from N9210/9290, 
S60 or by business card), they internally keep their properties. Contacts application displays them as 
its “standard” fields Phone (w), Mobile (w) or Fax (w), Email (w) and Web (the Web field is actually 
Web (w), in P800/900, though it is not displayed in this way). Those field types can be called 
acceptable. They are imported and exported by Contacts Manager+ without changes (i.e. as items 
without additional properties). 
 
Some unsupported field types can partly be maintained in the UIQ phone – we call them conceded 
ones – and other fields may be hidden (see further text).  
 
Following field types cannot be created internally, can be only fetched externally in vCard (via infra, 
Bluetooth or SMS) and they can be stored in the database. They are visible in the smartphone’s 
contact card – but without differentiating label (we call them semi-conceded fields). They are imported 
by Contacts Manager+ almost without changes. If they contain valid data in the contact card, they are 
exported into the “Misc.” column. 
 
1300 Middle name Additional name subfield of Name field Single
1400 Title Name prefix subfield of Name field Single
1500 Suffix Name suffix subfield of Name field Single
4200 Pager Pager field Multi 
4206 Other Pager Pager field renamed with user string Multi 
4207 Other Pager - desc. User string in Pager (.....) field if it is renamed  
3100 P.O. Box P.O. Box subfield of Address field Single
3200 Extension Extension subfield of Address field Single
3102 P.O. Box (Business) P.O. Box subfield of Business address field Single
3202 Extension (Business) Extension subfield of Business address field Single
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3103 P.O. Box (Home) P.O. Box subfield of Home address field Single
3203 Extension (Home) Extension subfield of Home address field Single
 
Other semi-conceded field types, such as LABEL, ROLE, URL (HOME), FN, MAILER, GEO, and 
SOUND, are imported into the Note field. 
 
The ‘Birthday’ item is imported and exported without change (if contains valid data) by Contacts 
manager+. It is hidden field (not displayed in the contact card window), but it is being sent out in the 
business card. 
 
2006 Birthday Birthday field Single
2007 Birthday - desc. User string in Birthday (.....) field if it is renamed  
 
More information about conceded and hidden fields can be found in the “Smart Export Features” 
chapter. 
 
In comparison with Nokia 9210/9290, there are no pure “preferred” fields – this property is partly 
substituted by the “Show in list” feature. In SE P800/900 contacts database, selected number in 
Phone (w), Phone (h), Mobile (w), and Mobile (h) fields can have the ‘preferred’ property (it is set by 
the “Show in list” option). The ‘preferred’ property can often be seen in business cards, in the Nokia 
92xx contacts database can be used even as one of main properties, in SE P800/900 it is usually 
used as an additional feature – similarly like the ‘default’ property in Symbian Series 60 phones. 
During import and export, the ‘preferred’ property is ignored, except of the case it belongs to the 
Address field. 
 
4001 Tel (Preferred) Tel field with property Multi 
4101 Tel GSM (Preferred) Tel GSM field with property Multi 
4301 Fax (Preferred) Fax field with property Multi 
4501 Mail (Preferred) Email field with property Multi 
 
One of unsupported fields (if it is not ‘preferred’ as well) is also Address field: 
Address (without property) is:  

- stored as “Home” Address when this field is free,  
- stored as “Company” Address (i.e., “Work”) when the Home address field is not free, 
- ignored (not stored at all) if none of both mentioned fields is free. 

If it has also ‘preferred’ property, it is stored additionally (besides storing it eventually as Home 
address or Company address) also as an “other” (preferred) Address. That means, it appears as a 
“conceded” Address, in Contacts. In this case, the field might occur twice in the contacts card, both as 
normal Home address field (if it is free) or Company address field (if it is free), and the “conceded” 
Address field. Both ‘Address’ and ‘Address (pref.)’ field types are imported by Contacts Manager+ as 
‘Address (pref.)’ field types. An ‘Address (pref.)’ field is exported by the application as an ‘Address’ 
field. 
 
And – compared with N9210/9290 – following seven field types don’t exist here at all (P800/900 
phones don’t use them). When they are imported (from N9210/9290, by vCard, etc.), they internally 
keep their properties, but Contacts application displays them in the same way like “normal” fields “Tel”, 
“Tel GSM”, or “Fax”. ’URL address (Home)’ field is displayed as the “unknown” item. The ‘Car’ and 
‘Data’ properties are unsupported though and are kept with the contact field only until the contact is 
edited. So, the Contacts Manager+ exports/imports them as “normal” fields ‘Tel’, ‘Tel GSM’, ‘Fax’, 
‘URL address’.  
 
4004 Tel (Car) Tel field with property Multi 
4005 Tel (Data) Tel field with property Multi 
4104 Tel GSM (Car) Tel GSM field with property Multi 
4105 Tel GSM (Data) Tel GSM field with property Multi 
4304 Fax (Car) Fax field with property Multi 
4400 Fax GSM Fax GSM (= Fax/mobile) field Multi 
4703 URL (Home) URL field with property Multi 
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From other devices also various modifications of these fields can be imported. They also appear 
without differentiating label (i.e., as hidden, conceded or semi-conceded fields). They are exported and 
imported in their basic form – without properties, e.g., like ‘Fax’, etc. Those fields can be, e.g.: 
 
4401 Fax GSM (Preferred) Fax GSM (= Fax/mobile) field with property Multi 
4402 Fax GSM (Business) Fax GSM (= Fax/mobile) field with property Multi 
4403 Fax GSM (Home) Fax GSM (= Fax/mobile) field with property Multi 
 
Multi-fields 
 
If there is “multi-field” (i.e. repeating fields) in any contact card, then multi-lining (with repeated lines) is 
used for export of such a contact, and in this case, contents of five “name-regarded” fields (never 
repeated in contact card itself) – ‘Last name’ etc. – are copied into each line belonging to the same 
contact (lines with the same ID).  
 
So if, for example, “Parker John“ contact card has three fields Phone (w), one Mobile (w), and two 
Email (w) addresses, then corresponding columns of its export will look like this:  
 
ID Last name First name ... Tel (Business)      ..... Tel GSM (Business) ..... Mail (Business)  
... 
865 Parker John  +999333222111 +888777000111 mail1@company.com 
865 Parker John  +999444777666    mail2@company.com 
865 Parker John  +999555000888     
 
All of these lines are related to the same contact card in the database – called John Parker. In the 
case of another John Parker in the database, he will have a different ID in the first column to avoid 
confusion when sorting contacts in MS Excel, etc. 
 
1584 Parker John  +999321321321 +888666555111 parker@comp.org 
 
If in doubt with unclear situations (e.g., after sorting the sheet by the ‘Last name’ or ‘Company’, etc), 
always check whether these lines have the same ID.  
 
Renamed Fields 
 
Creating of fields with user-defined description such as “Tel (lodge)” or “Fax (1st floor)” is not 
supported in SE P800/900 contacts database, but if such a field is imported using Contacts Manager+, 
its renaming string is stored in the database. Renamed field is imported and exported together with 
this string by the Contacts Manager+ application (only with some supported types), but, in the 
Contacts window, it is displayed without this string. Renamed fields of unsupported types are imported 
into the common Note field.  
 
“Note” and “Private Note” Fields 
 
Notes marked as “Private” are exported (if their export is enabled in Settings) – so as they are 
recognized from “normal” notes – as if they were renamed, i.e. into the ‘Other Note’ column, and in the 
‘Other Note – description’ column, the ‘Private’ string is written. 
 
All ‘Note’ items, when imported, are merged together with “unknown” items into a single Note field. 
User renaming of the ‘Note’ cannot be used in UIQ, and is ignored (imported without this string).  
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Types of Records in the Contacts Database 
 
A contacts database, along with contact cards, contains in addition other record types, such as 
definitions of contact groups (folders), templates (in some devices – e.g. Nokia 92xx – also voice 
mailboxes), and others. 
 
Contacts databases in SE P800 and P900, immediately after they are created, contain several pre-
defined records, such as:  
Group “RingToneGroup” (in P800 with ID=1, not present in P900) – hidden virtual group, contains 
contacts that have individual ringing tone assigned. 
Group “VoiceDialGroup” (in P800 with ID=2, not present in P900) – hidden virtual group, contains 
contacts that have voice dial tag assigned. 
Template ”SIM Card Contacts“ (in P800 with ID=3, in P900 with ID=1) – used internally for proper SIM 
card contacts mapping to the contacts database in the device. 
Unnamed group (in P800 with ID=4, in P900 with ID=2) – hidden virtual group, contains mapped SIM 
card contacts. 
 
Additionally, two default visible groups (folders), Personal and Business, are always created in the 
contacts database.  
 
The “Contact card” record type 
 
Contact cards are designed for storing phone numbers, addresses, and other data of the contact 
persons. 
 
Contacts in the internal memory and SIM contacts 
 
SIM contacts create the special contacts group. They can be exported from P800/900 if you enable 
exporting SIM contacts in the Settings. 
 
In the export table, SIM card contacts are displayed as members of the special group (folder). This 
group (folder) has empty name (it is hidden) in the database.  
 
The “Template” record type 
 
Template definitions are usually stored in the contacts database, too. A template defines what fields 
will be pre-defined for each new contact card. Contacts database in SE P800/900 contains one default 
template – for proper mapping of SIM card contact fields to the main contacts database (template for 
creating new cards is stored in another place). 
 
In the exported file, each template definition is marked in the ‘Misc. - type’ column with the identifier 
“0200 Template”. Then the ‘Misc. - desc.’ column usually contains the ”Template Label“ string, and the 
‘Misc.’ column contains a template name. Those fields which are set as valid in a template definition 
contain the ‘TRUE’ string in the export table (actually, any text is allowed). Fields that are set as “off” in 
the template are empty here.  
 
Exporting of templates can be enabled/disabled in the Tools->Settings->Export content->Templates 
item setting. Templates are placed at the beginning of the exported contacts list.  
 
The “Contacts group (folder) definition” record type 
 
Group definitions (folders) are also contacts database items. They contain data about their members. 
If a database contains group definitions, each group has its own data line(s) like normal contact – with 
the group name in the ‘Last name’ column. In the export table, each group is marked with the “0400 
Group” identifier in the ‘Misc. - type’ column. The ‘Misc.’ column contains information about the 
number of its members (e.g. “5 members”). Each row containing a group definition corresponds with 
the data in the ‘Member’ column that contains the ID and the name of a group in the contact’s row.  
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Exporting of group definitions (folders) can be enabled/disabled in the Tools->Settings->Export groups 
(folders) item setting. Group definitions are exported onto the end of the table, after the contacts list 
(regardless of their IDs). When groups (folders) exporting is disabled, groups definitions and ‘Member’ 
fields content are not exported. 
 
Contacts database in SE P800/900 contains three standard pre-defined folders (groups) – ’Business’ 
and ‘Personal’ groups and one unnamed group (folder) for mapped SIM card contacts. 
 
Note:  

• In P800/900, each contact can normally be only in one group (folder) at a time. By data import 
using Contacts Manager+, you can assign contact to more than one group. 

• User can create other folders (groups).  
• P800/900 contacts database doesn’t support “inclusive” groups. If an imported file (created, 

e.g. in Nokia 92xx) contains group definitions where a group is a member of another group, 
this “secondary” membership is ignored. 

 
Default (preferred) item 
 
In the contact card, you can set up some kind of ‘preferred’ number (using the “Show in list” function). 
Such a number can be only in following fields: Phone (w), Phone (h), Mobile (w), and Mobile (h).  
 
During import and export, the ‘preferred’ property is ignored, except of the case when it belongs to the 
‘Address’ field. 
 
If the ‘Address’ field in the received business card has the ‘preferred’ property, it is stored additionally 
(besides storing it eventually as Home address or Company address) also as an “other” (preferred) 
Address. That means, it appears as a “conceded” Address, in Contacts. This behavior is exploited in 
import, and both ‘Address’ and ‘Address (pref.)’ field types are imported by Contacts Manager+ as 
‘Address (pref.)’ field types. That’s because without the ‘preferred’ property, an unsupported ‘Address’ 
field wouldn’t appear in Contacts at all. In this case, the field might occur twice in the contacts card, 
both as normal Home address field (if it is free) or Company address field (if it is free), and the 
“conceded” Address field, of course. An ‘Address (pref.)’ field is exported by the application without 
this property, i.e., as an ‘Address’ field. 
 
Smart Export Features 
 
Exporting contacts might also discover hidden data stored in your contacts database that the Contacts 
application doesn’t show – or doesn’t fully display.  
 
And, in some cases, Contacts Manager+ is able to recover data from corrupted contacts database. 
 
“Repair” Function 
 
Although there are no “full” repair functions in Contacts Manager+, it is also able to repair corrupted 
database in some cases. If a corrupted database cannot be opened in the Contacts application, you 
can try to export its data with Contacts Manager+ into a textual file. Export will skip corrupted contact 
item. The faulty database can be then deleted and the exported data can be imported into a new, 
empty database – without corrupted contact.  
 
Contacts Manager+ can also recognize incomplete “compact” entries that may be ignored by the PIMs 
(MS Outlook, Lotus Notes ...) during synchronizing. These fields are usually visible in smartphone’s 
contact card window, but they are often omitted by the synchronizer. No such fields can be created 
from the smartphone’s keypad, though. They are usually created when a business card is received via 
infrared or SMS, especially if sending phone sends it with contracted field headers (compact business 
card). These fields (in most cases phone number fields) are properly exported into the result file by the 
Contacts Manager+, of course. 
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Conceded, Hidden and Special Fields 
 
Database entries can contain more field types in contact cards than user can create or even see in the 
contact card window.  
 
“Conceded” Fields 
 
Conceded fields are those field types, which can only be fetched externally (via infra, Bluetooth, or 
SMS) and not created internally in the usual way. They are visible in the smartphone’s contact card. In 
P800/900, all such fields are only semi-conceded fields and they have no visible label. 
 
Following field types, if they are present in imported contacts data, or in received business card, are 
stored with the contacts data. They are displayed as “unknown” field types, in the contact card. 
Contacts Manager+ exports these fields into the common ‘Misc.’ column. They can be:  
 
Middle name [1300],  
Title [1400],  
Suffix [1500],  
Pager [4200],  
Other Pager [4206],  
PO BOX [3100], 
Extension [3200],  
PO BOX (Business) [3102], 
Extension (Business) [3202],  
PO BOX (Home) [3103],  
Extension (Home) [3203]. 
 
The field types above are imported by Contacts Manager+ almost without changes. 
 
LABEL – contains formatted unstructured address and is displayed as a single-item field in the 
contact card. Caution! This formatted address field must not be confused with the regular 
smartphone’s structured “address” fields created of sub-fields (P.O. Box; Extension; Street; ZIP/Postal 
code; City; State/Province; Country/Region).  
ROLE – belongs to the company data; its meaning is “Job description”,  
URL;HOME – Web address with ‘Home’ property,  
FN – formatted unstructured name,  
MAILER – name of the mail client application 
GEO – geographical information (longitude and latitude),  
SOUND – binary data or path to the sound file (when received in a business card, it is not stored as a 
P800/900’s ringing tone but as unknown semi-conceded field),  
These field types are imported by Contacts Manager+ into the Note field. 
 
Additionally, during synchronization, some unspecified or non-standard fields might be imported. 
 
“Hidden“ Fields 
 
Similarly, hidden fields (invisible in the contact card) can be only fetched externally (via infra, Bluetooth 
or SMS) and they cannot be created form the keypad. But, unlike the conceded fields, they are not 
displayed in the contact card window. Examples: 
BIRTHDAY – if received in business card or during synchronization, it is stored into the contacts 
database. Contacts Manager+ exports and imports it without changes. 
NICKNAME – if received in business card or during synchronization, it is stored into the contacts 
database. Contacts Manager+ exports it as an unknown hidden item, imports it into the Note field. 
 
Hidden Properties of Fields  
 
Certain field types can contain subtypes (properties) that are not seen in the contact card window. 
They are usually imported from another device or received in a business card.  
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“Special” Fields 
 
Special fields are linked to the sound or picture data and are sometimes created by another 
application in the smartphone. 
 
Ringing tone – individual ringing tone of the certain contact person. This field has its own column in 
the exported file.  
Speed dial – speed dial key for selected phone number of the contact person. Phone number that the 
speed dial key is referred to is shown (i.e., repeated) in the ‘Misc.’ column. In the ‘Misc. - type’ column, 
the speed dial key assigned is displayed. There is also information about the phone number type 
(header of a column containing primarirly this number) in this item data. 
Picture – contact picture file(s). This data has its own column in the exported file. In the Tools-
>Settings->Export picture data, you can set whether whole contact picture data (JPEG format, Base64 
encoding) will be exported into the ‘Picture’ column, or only ‘TRUE’ flag (where acceptable) will be set 
in this column.  



 
Contacts Manager+ for SE P800/P900 (UIQ) 11 © AGORA plus, a.s., 2002-2004 
 

Import into Symbian UIQ phone (SE P800, P900) 
 
You can import the CSV/TXT file created by export from Symbian UIQ phone, Symbian Series 60 
phone, or Nokia 9210/9290 phone (or created manually using the CntMng export protocol format 
definition). You can also transfer contacts databases between communicators or phones.  
 
Note: Before using this tool, do a fresh backup of the data in your phone! 
 
To import contacts from common device or memory card storage, press the Import button (or select 
Contacts->Import contacts). Choose the file you want to import data from, accept the warning 
message, and by pressing Yes button, confirm adding imported contacts into the main contacts 
database.  
 
Standard and recognized items are imported into proper fields. Unrecognized or unknown items are 
written in this ‘Note’ field by the contacts, in a textual form. 
 
Import of group definitions (or folders) is supported (an “inclusive” membership of groups is ignored). It 
is optional feature – during contacts import, you are asked whether groups are to be imported. 
Note: The application checks, before importing groups, whether Contacts application is closed. If it is 
open, you are offered with closing it. If you press ‘No’, groups are not imported. 
 
Import of Picture/Photo and Sound/Ringing data is supported. 
 
The picture size is not checked when imported and the picture is imported “as is”. Only when the data 
format is invalid, the picture is not imported, and this fact is marked in the Note field. 
 
When importing ringing file data given as a path to the file, it is imported only when the path is valid. If 
the path is not valid, it is imported only into the Note field. 
 
Creating of fields with user-defined description such as “Tel (lodge)” or “Fax (1st floor)” is not 
supported in SE P800/900 contacts database, but, if such a field is imported using Contacts 
Manager+, its renaming string is stored in the database. Renamed field is imported and exported 
together with this string by the Contacts Manager+ application (only with some supported types), but in 
the Contacts window, it is displayed without this string. 
 
For more details about import features in the current version of the application, please check the 
readme.txt file.  
 
Import into Symbian Series 60 Phone  
(Nokia 7650/3650/3660/6600/N-Gage, Siemens SX1 and Other Types) 
 
For instructions, please read user’s guide of Contacts Manager for Series 60. 
 
Import into the Nokia 9210/9290 Communicator 
 
For instructions, please read user’s guide of Contacts Manager for Nokia 9210/9290. 
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Import into the Microsoft Excel Application 
 
The data file is coded in Unicode, so you can import it directly into MS Excel 2000 or newer versions.  
 
When importing it into older Excel versions (without Unicode support), e.g. Excel 95/97, first open 
the Unicode-coded file with MS Word (or another capable editor), save it – again in plain textual form – 
in appropriate national coding, and then it is ready to be imported into older version of MS Excel. 
 
Keep the Proper Procedure 
 
To prevent distorting phone numbers when loading exported data into MS Excel, it is important to 
import them as “text”, not “numbers” or “general”. Although user can set cells format in the empty 
Excel sheet as "text", this setting is valid only for typing, not for importing. As soon as you paste or 
straight-import data into these cells, this setting is ignored, and data is imported in "general" format. 
Phone numbers might then be distorted and long data strings truncated to 255 characters only. 
 
Before exporting, you should ensure that Settings in Contacts Manager+ are set in the recommended 
way: 
Cell separator: comma (default) or semicolon (change it so if necessary) 
String qualifier: quote (default)  
You may use the “apostrophe” qualifier if necessary, but don’t use “tab” separator (delimiter) in the 
case you need to import the file into MS Excel. 
Save the exported file with chosen name and .csv extension. Continue with the “a” section. 
 
If you have data exported with “tab” delimiter, the file should have .txt extension. For proper importing 
of such a file, please skip this “a” section and follow the “b” section instead. 
 
a) Having the Data in CSV File 
 
If you have created a comma or semicolon delimited file with CSV extension, you can open it – as an 
associated file – by simply double-clicking on the file (application will open automatically). Or you can 
use MS Excel’s function File->Open... 
 
But neither comma nor semicolon delimiters are expected to be default ones in MS Excel. So all data 
is loaded into the “A” column. 
 
In CSV format, user can use "text qualifiers" (quotes or apostrophes), but this doesn't influence the 
format in which the data is imported or pasted into the cell. Text qualifier is important in the case that 
text strings may contain the same characters as those used as delimiters, and this becomes the way 
to differentiate valid characters from delimiters. But text qualifier never ensures that text strings will be 
imported by MS Excel as text strings. This has to be ensured in a different way (see further). 
 
Select (mark) the “A” column containing the data, and select Data->Text into columns. This will run 
the importing Wizard. If you used Data->Read external data->Import text file instead of opening a 
file, you would get a very similar wizard. 
 
In the first Wizard window choose ‘Delimited’ option and click on Next. In the second Wizard window 
choose proper ‘Delimiter’ and ‘Text qualifier’ (according to the Settings in Contacts Manager+, i.e. 
comma and quotes if it is in default recommended setting).  
Note – the ‘Treat consecutive delimiters as one’ option MUST NOT be selected (the box next to it has 
to remain empty)!  
Click on Next.  
 
Now we have reached a very important moment for proper format settings. First column in 'Data 
preview' table in the lower half of the third Wizard window is selected (= in black) and prepared for 
format change. But we need to set ALL columns into "text" format. So press and hold the Shift key, 
and jump to the last column in the preview (the fastest way is to move the slider to the far right edge) 
and click on the last column's header tab. Now all the columns should be black (= ‘selected’). In the 
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‘Column data format’ list, select the ‘Text’ option. Header tabs of all columns must change from 
‘General’ to ‘Text’. 
Press Finish. 
 
Now data is correctly imported, and phone numbers are represented properly (the "+" sign is OK, 
spaces are OK, data strings of pictures or ringings are not truncated). 
 
Note: You can do it easily using our Excel macro (see Appendix A). 
 
b) Having the Data in the TXT File 
 
TXT file is the case when “tab” is the chosen delimiter. This format doesn’t need text qualifiers, so 
sometimes this option is set as “none”.  
 
Don’t use File->Open function for loading the data into MS Excel, because it would open it in the 
wrong format with distorted phone numbers and truncated data strings. Create a new (empty) sheet 
and select Data->Read external data->Import text file. Browse text files – select ‘File types: text files 
(*.txt)’, find your exported text file in TXT format (tab delimited), and press Import button. That will run 
the importing Wizard. 
 
In TXT format, a user can also use "text qualifiers" (quotes or paragraphs), but this doesn't influence 
the format in which the data is imported or pasted into cell. Text qualifier is important in the case that 
text strings may contain the same characters as those used as delimiters, and this is the way to 
differentiate valid characters from delimiters. But text qualifier never ensures that text strings will be 
imported by MS Excel as text strings. This has to be ensured in a different way (see further). 
 
In the first Wizard window choose ‘Delimited’ option and click on Next. In the second Wizard window 
choose proper ‘Delimiter’ and ‘Text qualifier’ (according to the Settings in Contacts Manager+, e.g. the 
“tab” delimiter and “none” qualifier).  
Note – the ‘Treat consecutive delimiters as one’ option MUST NOT be selected (the box next to it has 
to remain empty)!  
Click on Next.  
 
Now we have reached a very important moment for proper format settings. First column in 'Data 
preview' table in the lower half of the third Wizard window is selected (= in black) and prepared for 
format change. But we need to set ALL columns into "text" format. So press and hold the Shift key, 
and jump to the last column in the preview (the fastest way is to move the slider to the far right edge) 
and click on the last column's header tab. Now all the columns should be black (= ‘selected’). In the 
‘Column data format’ list, select the ‘Text’ option. Header tabs of all columns must change from 
‘General’ to ‘Text’. 
Press Finish. 
 
Now data is correctly imported, and phone numbers are represented properly (the "+" sign is OK, 
spaces are OK, data strings of pictures or ringings are not truncated). 
 
Note: You can do it easily using our Excel macro (see Appendix A). 
 
Editing the File 
 
You can edit file with changing its data. Be careful doing so and keep the proper format of  the fields 
content. 
 
Warning: 
While working with the data table in a spreadsheet application, never remove the “A” column with ID 
data.  
When sorting items by any header (Last name, Company ...), always select ALL columns. 
Cell format has always to be set in the way that data is interpreted as “text”, and not as “number” or 
“general” data. 
 



 
Contacts Manager+ for SE P800/P900 (UIQ) 14 © AGORA plus, a.s., 2002-2004 
 

If you would like to import the data back into a phone or communicator using this program, don’t edit or 
remove the first two lines containing the export protocol identifier and the column-numbering headers.  
 
Saving Data from MS Excel to CSV format 
 
After editing, check the valid content of cells, as import doesn't check the data type. Don't put "invalid" 
characters in the "phonenumber" fields. The application will import whatever entered, but you might 
have problems dialing a “number” with invalid characters. 
 
1) Check the table and remove all empty existing rows within the range. 
 
2) Select File->Save as... and choose “File type”:  

- either "CSV (comma separated value)"  
- or "Text (tabs delimited)"  
- or "Text in Unicode" (recommended when transferring into an other-language 

communicator/smartphone/PDA). 
 
3) Save the file 
 
Now you can send the file to a phone via infrared or Bluetooth, or move the file to a phone using PC 
Suite.  
 
Warning! When moving the CSV/TXT file into a phone using PC Suite (dragging it to the phone’s 
window), don't use "Copy and convert" (default dragging settings), but use "Copy only" with the right 
mouse button pressed and held while dragging. Otherwise, the system may change the file structure 
(from plain text to Epoc format) and the file import will fail. 
 
Manual Creating of the Textual File Using MS Excel 
 
User can also create the textual file for Contacts Manager+ manually: 
 
1) Create an empty MS Excel table with the proper header. The “starting” table can be taken from an 
empty Contacts Manager+ export file. 
 
2) Fill in the contacts data into cells. In the column 0000, assign the unique ID to each contact. Each 
contact record can have as many rows as needed for entering all required data of the contact. Table 
rows belonging to the same contact must have identical ID in the column 0000. Content of ‘Last name’ 
and ‘First name’ items should be repeated in all rows belonging to the same contact.  
 
3) Follow the “Saving Data from MS Excel to CSV format” paragraph mentioned above. 
 
By using the “empty“ Contacts Manager’s form, you get automatically pre-filled headers of all columns 
you might wish to use. Their description can be found in the table in the chapter “Exported File – the 
Format and the Structure”. But in the case you would like to define groups, or assign additional 
properties (speed dial, default number/address) to some contacts data items, you have to know 
numerical identifiers of these properties, and state them in the columns 99xx.   
 
010k – Speed dial, k means speed dial key number 

0102 – 0109 (speed dials on keys 2 to 9) 
Speed dials import is currently not supported in the UIQ application version. 
Speed dials import is supported in the Series 60 application version. 
In the N9210/9290 application version, speed dials import is not supported (contacts are 
always imported into secondary database which doesn’t support speed dials).  
 

0200 – Template 
 Templates import is currently not supported in none of existing versions of the application. 
 
0300 – Member 
 Uses its own columns, cooperates with groups (folders). 
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0400 – Group 
  Groups (folders) import is supported in UIQ, Series 60 and N9210/9290 application versions.  
 
0500 – Own card 

Series 60 phones don’t use contact database records for own card definition settings. 
In the N9210/9290 application version, own card import is not supported (contacts are always 
imported into secondary database which doesn’t support own card).  
Currently it is only partly supported in UIQ version. 

 
06dd – Default item, dd=11, 12, 13, 14 
 0611 – Default phone 

0612 – Default SMS 
0613 – Default MMS 
0614 – Default e-mail 
The ‘Default’ item types exist only in Series 60 phones contact databases, and their import is 
supported. 
Note: This version cannot provide full mutual conversion between the ‘Default’ attribute (by 
Symbian UIQ and Symbian Series 60) and the ‘Preferred’ assigning (by Nokia 9210/9290) yet.  
Currently not supported in UIQ version. 
 

0700 – Voice dial 
Voice dial import is not supported in any of existing version of Contacts Manager.  
Note: Voice dials are not fully exported with this application. During exporting, only remark 
about the voice dial tag existence is made with the contact data. Recordings themselves are 
not parts of contacts database. 

 
0800 – Voice mailbox 

Neither Symbian UIQ nor Series 60 phones use contact database records for voice mailbox 
definition settings. 
In the N9210/9290 application version, voice mailboxes import is not supported (contacts are 
always imported into secondary database which doesn’t support voice mailboxes).  
 

Using the “Misc.” Columns 
 
Columns marked as “Misc. ...” can be used both for entering those item types that don’t have their own 
column (so called “unknown” items), and for assigning additional properties to items that have their 
own column. 
 
Creating Folders (Groups) Using CSV File 
 
Note:  

• In SE P800/900, each contact can normally be only in one group (folder) at a time. By data 
import using Contacts Manager+, you can assign contact to more then one group. 

• SE P800/900 contacts database doesn’t support “inclusive” groups. If an imported file 
(created, e.g. in Nokia 92xx) contains group definitions where a group is a member of another 
group, this “secondary” membership is ignored. 

 
0000 1100 1200 … 0300 9906 9999 9907 
ID Last name First name … Member Misc. Misc. - type Misc. desc. 
128 Public John … 133 (Friends)    
129 Known Ray …     
131 Seldom Robinson … 133 (Friends)    
133 Friends  …   0400 Groups  
 
Descriptions next to numberings in columns 0300 and 9999 are not mandatory and they can be 
omitted – the table then would look like this:  
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0000 1100 1200 … 0300 9906 9999 9907 
ID Last name First name … Member Misc. Misc. - type Misc. desc. 
128 Public John … 133    
129 Known Ray …     
131 Seldom Robinson … 133    
133 Friends  …   0400  
 
... but it is better to use them as comments, at least for your future understanding of table data. 
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Converting Exported Pictures/Thumbnails from a String of 
Characters to a JPEG File 
 
At the moment, it is not possible to import exported pictures directly to MS Excel. The export format is 
textual, so the binary data – if the database contains it – is encoded into a text string as well.  
 
When data is imported into cells in “General” format, MS Excel truncates all text strings (including the 
picture data string) to 255 characters. That’s why it is necessary to import them in “Text” format, as 
described in the “Import into the MS Excel Application” chapter.  
 
So it must be decoded from Base64 encoding to binary first. It can be done using any suitable MIME-
decoding program.  
 
The procedure: 
1) Create a new empty plain text file (via Notepad or similar program).  
2) Copy picture data string from CSV file into the clipboard (it is recommended to take data directly 
from the TXT or CSV file, as it could be truncated in Excel sheet).  
3) Paste the data string of the picture into the text file and add a MIME header: 
 
------------------------------------------------- 
MIME-Version: 1.0 
Content-Type: application/octet-stream; name="contact.jpg" 
Content-Transfer-Encoding: base64 
 
|->put the encoded string here<-| 
------------------------------------------------- 
 
where the "contact.jpg" is the target name of the picture file. 
Now apply the decoding procedure to this text file using the MIME objects decoder. 
 
You can do it in the batch: 
------------------------------------------------- 
MIME-Version: 1.0 
Content-Type: application/octet-stream; name="contact1.jpg" 
Content-Transfer-Encoding: base64 
 
|->put the encoded string of the picture of the "CONTACT1" person here<-| 
 
Content-Type: application/octet-stream; name="contact2.jpg" 
Content-Transfer-Encoding: base64 
 
|->put the encoded string of the picture of the "CONTACT2" person here<-| 
 
etc. 
------------------------------------------------- 
 
If you apply the decoding procedure to this multi-data file, you will get all pictures in this file – in one 
step decoded. 
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Appendix A: 
 
Using Macros for Easier CSV File Importing into MS Excel 
 
If you have exported CSV file in the default format and you click on it in Windows, it opens in the first 
column of Excel sheet. You can use the “Text to columns” function, as described in the chapter “Import 
into the Microsoft Excel Application”, or you can use our macro. 
 
The ‘CSV-to-columns-keeping-text-as-a-text” macro (for up to 81 columns 
import), if the CSV file format is:  
Text qualifier=quotes, Fields separator=comma 
 
This macro works with up to 81 columns so you can use it for the UIQ version (with 56 columns in the 
CSV file), for the Series 60 version (with 68 columns in the CSV export file) as well as for the 
N9210/9290 version (with 81 columns in the CSV export file). 
 
It can be used only for CSV settings with quotes as the text qualifiers and commas as the field 
separators. For different CSV settings (different text qualifier and field separator) this macro needs to 
be changed. 
 
The macro is available for downloading on the application’s homepage – see 
http://www.communicator.cz. Its name is “81columns.bas”. 
 
 
Listing of the macro: 
 
 
Sub CSVTo81TextColumns() 
' 
' CSV To 81 Text Columns macro 
' For Contacts Manager 
' If the format is: Qualifier=quotes, Delimiter=comma 
 
' 
    Columns("A:A").Select 
    Selection.TextToColumns Destination:=Range("A1"), DataType:=xlDelimited, _ 
        TextQualifier:=xlDoubleQuote, ConsecutiveDelimiter:=False, Tab:=False, _ 
        Semicolon:=False, Comma:=True, Space:=False, Other:=False, FieldInfo _ 
        :=Array(Array(1, 2), Array(2, 2), Array(3, 2), Array(4, 2), Array(5, 2), Array(6, 2), _ 
        Array(7, 2), Array(8, 2), Array(9, 2), Array(10, 2), Array(11, 2), Array(12, 2), Array(13, 2 _ 
        ), Array(14, 2), Array(15, 2), Array(16, 2), Array(17, 2), Array(18, 2), Array(19, 2), Array _ 
        (20, 2), Array(21, 2), Array(22, 2), Array(23, 2), Array(24, 2), Array(25, 2), Array(26, 2), _ 
        Array(27, 2), Array(28, 2), Array(29, 2), Array(30, 2), Array(31, 2), Array(32, 2), Array( _ 
        33, 2), Array(34, 2), Array(35, 2), Array(36, 2), Array(37, 2), Array(38, 2), Array(39, 2), _ 
        Array(40, 2), Array(41, 2), Array(42, 2), Array(43, 2), Array(44, 2), Array(45, 2), Array( _ 
        46, 2), Array(47, 2), Array(48, 2), Array(49, 2), Array(50, 2), Array(51, 2), Array(52, 2), _ 
        Array(53, 2), Array(54, 2), Array(55, 2), Array(56, 2), Array(57, 2), Array(58, 2), Array( _ 
        59, 2), Array(60, 2), Array(61, 2), Array(62, 2), Array(63, 2), Array(64, 2), Array(65, 2), _ 
        Array(66, 2), Array(67, 2), Array(68, 2), Array(69, 2), Array(70, 2), Array(71, 2), Array( _ 
        72, 2), Array(73, 2), Array(74, 2), Array(75, 2), Array(76, 2), Array(77, 2), Array(78, 2), _ 
        Array(79, 2), Array(80, 2), Array(81, 2)) 
    Range("A1").Select 
End Sub 
 

 


